[FFmpeg-user] intel quick sync with ffmpeg

Jayram Moorkanikara Nageswaran nageswaran at braincorporation.com
Tue Mar 1 00:04:15 CET 2016


My current system:
OS: Ubuntu Linux  14.04 with 3.14.5-MSSr6 #1 SMP.
Hardware: Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz

1) I managed to complete the detailed instruction for installing intel
media sdk on generic Linux OS.
I followed the instruction given in
- https://ffmpeg.org/pipermail/ffmpeg-user/2015-October/028761.html

2) I also compiled the latest ffmpeg from github following the procedure
presented in

3) I was testing compression of video camera feed using the command

>> /opt/ffmpeg_qsv/bin/ffmpeg -f v4l2 -framerate 30 -video_size 640x480 -i
/dev/video0 -c:v h264_qsv out.mp4 -loglevel 1000000

*I got the following error:*

[h264_qsv @ 0x2e327e0] Error initializing an internal MFX session
Error while opening encoder for output stream #0:0 - maybe incorrect
parameters such as bit_rate, rate, width or height

*Things that I tried:*
1) ensure user is part of video group
2) Run the command with sudo and su
3) export LD_LIBRARY_PATH (export
4) add ld.so.conf
/etc/ld.so.conf.d/intel-mediasdk.conf -> /opt/intel/mediasdk/lib64
5) ldconfig -p -N | grep intel.mediasdk
    libmfxsw64.so (libc6,x86-64) => /opt/intel/mediasdk/lib64/libmfxsw64.so
    libmfxhw64.so (libc6,x86-64) => /opt/intel/mediasdk/lib64/libmfxhw64.so
6) Testing with a sample yuv file instead of camera feed got the same error

Please see the detailed log attached.

Any help to proceed next would be appreciated.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: ffmpeg.log
Type: text/x-log
Size: 5337 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20160229/9867b67a/attachment.bin>

More information about the ffmpeg-user mailing list