[FFmpeg-user] How to output the MPEG-4 streaming to file?

Yuki yn.musen at gmail.com
Wed Oct 26 09:37:58 EEST 2016

Reuben Martin wrote
> That’s hardly the same command, as it does not even output the same error.
> At least give some people the satisfaction that you’ve at least tried to 
> search. Cargo-cult copy-and-paste shows more effort than this.
> ffmpeg -i udp://@ -c:v copy -c:a copy -f mpegts 
> stream_dump.ts
> Also, MPEG4 Part-2 is a codec, not a format.
> ffmpeg -codecs | grep 'MPEG-4 part 2'

Thank you for your advice, and I'm sorry not enough question.

There is a multicast network and in the network, flowing data of H.264
MPEG-2 and Mpeg4 Part2.

I send igmp join and captured those packets. and restreaming in test network
using Colasoft Packet Builder.

When I use command "ffmpeg -i udp://@{IpAddr}:{Port} -c:v copy -c:a copy -f
mpegts stream_dump.ts", i got the following results.
  - H.264...OK.
  - MPEG-2...OK.
  - MPEG-4...NG. "Invalid data found when processing input" will occur.

I've uploaded a packet file of raw datas.
if you will assist me, please use this file.


View this message in context: http://ffmpeg-users.933282.n4.nabble.com/How-to-output-the-MPEG-4-streaming-to-file-tp4678001p4678011.html
Sent from the FFmpeg-users mailing list archive at Nabble.com.

More information about the ffmpeg-user mailing list