[FFmpeg-user] Strange output of ffprobe

Jerome Martinez jerome at mediaarea.net
Fri Oct 28 00:11:51 EEST 2016

Le 27/10/2016 à 18:06, Анатолий Коростелев a écrit :
> Hello!
> Recently I recieved a mp4 for playing. When I tried to play this file 
> I didn't hear any sound in some players (in ffplay sound worked). When 
> I looked at the metadata of this file (via ffprobe), I saw the following:
> [...]
> Then I used mediainfo utility to see the metadata of the file:
> [...]
> As you can see the "Sampling rate" in mediainfo is 7 350 Hz (it's 
> illegal value) 

It is not an illegal value, AAC specs authorize it.

> while "Sampling rate" in ffprobe is 48000 Hz. I think that the problem 
> with the sound of this file has been caused by encoder 
> errors/misconfiguration. But it's very strange that ffrobe always 
> shows me 48000 Hz Sampling rate. Is this a bug or something else?

48000 Hz seems the correct one, so no FFmpeg bug but MediaInfo bug (as a 
first shot, issue is that there is an ES descriptor without 
AudioSpecificConfig element in the track header and MediaInfo does not 
manage correctly this case; note that this may be the reason some 
players does not play sound).

Jérôme, developer of MediaInfo.

More information about the ffmpeg-user mailing list