[FFmpeg-user] ffmpeg x265 on multi-cpus

fred fred fr1d_mail at yahoo.fr
Mon Apr 10 12:58:59 EEST 2017

Dear list,I am currently on this equipment :
$lscpuArchitecture:          x86_64CPU op-mode(s):        32-bit, 64-bitByte Order:            Little EndianCPU(s):                24On-line CPU(s) list:   0-23Thread(s) per core:    2Core(s) per socket:    6Socket(s):             2NUMA node(s):          2Vendor ID:             GenuineIntelCPU family:            6Model:                 63Model name:            Intel(R) Xeon(R) CPU E5-2643 v3 @ 3.40GHzStepping:              2CPU MHz:               1244.585BogoMIPS:              6803.58Virtualization:        VT-xL1d cache:             32KL1i cache:             32KL2 cache:              256KL3 cache:              20480KNUMA node0 CPU(s):     0,2,4,6,8,10,12,14,16,18,20,22NUMA node1 CPU(s):     1,3,5,7,9,11,13,15,17,19,21,23
and $free -h              total        used        free      shared  buff/cache   availableMem:            62G        908M         54G        969M        7.2G         60GSwap:           67G          0B         67G

and tried to use ffmpeg last compilation, according to the ffmpeg installation page
$ffmpegffmpeg version N-85424-gadf9f04 Copyright (c) 2000-2017 the FFmpeg developers  built with gcc 4.8.5 (GCC) 20150623 (Red Hat 4.8.5-11)  configuration: --prefix=/ffmpeg_build --extra-cflags=-I/ffmpeg_build/include --extra-ldflags='-L/ffmpeg_build/lib -ldl' --bindir=/bin --pkg-config-flags=--static --enable-gpl --enable-nonfree --enable-libfdk_aac --enable-libfreetype --enable-libmp3lame --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265  libavutil      55. 60.100 / 55. 60.100  libavcodec     57. 92.100 / 57. 92.100  libavformat    57. 72.100 / 57. 72.100  libavdevice    57.  7.100 / 57.  7.100  libavfilter     6. 84.101 /  6. 84.101  libswscale      4.  7.100 /  4.  7.100  libswresample   2.  8.100 /  2.  8.100  libpostproc    54.  6.100 / 54.  6.100Hyper fast Audio and Video encoder

I have tried all possible ways to use all my 16 cpus (x2 threads) to encode with libx265, but each time it fails...
-pools, --pools, -p,  --numa-* ... and so on are not recognise at all
$ffmpeg -p 16 -i Ice.avi  -c:v libx265 -preset veryslow -crf 28 -c:a aac -b:a 128k Ice_x265.mp4Unrecognized option 'p'.Error splitting the argument list: Option not found
Internet and my friend Google didn't provide me with any solution...
so how to proceed ???
Thank you !RegardsFred

More information about the ffmpeg-user mailing list