[FFmpeg-user] Using ffmpeg to sanitize video with CyberLink PowerDirect 14

Paul Sheer paulsheer at gmail.com
Sun Aug 6 09:40:42 EEST 2017

Hi there,

I use ffmpeg as follows to transfer video from my Samsung Galaxy Note
2 and Samsung Galaxy Note 4 to PowerDirect 14:

ffmpeg.exe -i samsung-raw-video.mp4 \
  -qscale:v 1 -r 30 -codec:v msmpeg4  cooked-import-video.wmv

Now youtube wants 16:9 video and 1280x720 res seems like a good
compromise between quality and storage. I really see no need for
higher resolution, but anything lower starts to get closer to "regular
TV" video which is not acceptable. Also, 1280x720 is a sort-of
standard resolution on a Samsung Galaxy Note. Similarly for 30fps. So
this my reason for shooting all my video in 1280x720 at 30fps.

The problem is that many video editing suites get my audio out-of-sync
with the video -- this can really make your hair turn gray.  I was
told this is because those suites don't understand variable-frame-rate
encoding. Is that the reason?  So the trick is to convert the video
into "ANYTHING" that is 30fps and 1280x720 and Not loose quality.

What is this "arbitrary" video format that would be import-able into
PowerDirector???? I had no idea. I looked through the plethora of
different formats supported by ffmpeg. Some do not allow the specific
resolution of 1280x720 at 30fps.

After trying many formats I found that,

    -qscale:v 1 -r 30 -codec:v msmpeg4  output.wmv

, works well.

So that is the background. I have been doing all my videos like this.
My procedure is to process all the raw footage with the above options
as a first step before I start editing. Here is my channel:


So my problem is solved.

So these are my questions please:

What really is the "proper" way of processing video from Android with
this problem of the "variable-frame-rate (??)" un-syncing the audio?
How do other people do it?
What is a good intermediate format that does not alter the resolution,
quality, and uses 30 fps?
What is special about "msmpeg4" that it seems like the only format I
could find that worked well for importing into PowerDirector and also
met my criteria?
Why does ffmpeg reduce the resolution down to worse-than-VHS quality
when I omit the "qscale" option?
Surely retaining the quality should be the default when converting to
a different format?



More information about the ffmpeg-user mailing list