[FFmpeg-user] FFmpeg - C compiler test failed

sujaypatil0055 sujaypatil0055 at gmail.com
Thu Dec 7 16:03:29 EET 2017

I have been trying to build ffmpeg 3.4 from 3-4 days but i am not able to
create shared libraries (.so) files.

1.When i run shell script build file it gets end up with saying "C Compiler
test failed"

My build_ffmpeg.sh file--
./configure --prefix=$(pwd)/android/arm	\
--sysroot=$NDK/platforms/android-9/arch-arm/ \
--enable-shared \ 
--disable-static \   
--target-os=linux \
--cpu=arm7 \
--arch=arm \
--disable-asm \
--disable-stripping \
--extra-cflags="-O3 -marm -Wall -pipe -std=c99 -ffast-math -fstrict-aliasing
-Werror=strict-aliasing -Wno-
psabi -Wa,--noexecstack -DANDROID -DNDEBUG-march=arm7 -mtune=arm7
-msoft-float" \
--extra-ldflags='-L../x264 -Wl,--fix-cortex-a8 -L../android-libs
-Wl,-rpath-link" \

2.I tried to upgrade ubuntu 14.04 to ubuntu 16.04 but still an error
3.Generated config.log file shows at end line "permission denied" 
config.log <http://www.ffmpeg-archive.org/file/t378344/config.log>  
4.After trying some solutions the error "C compiler test failed" got
bypassed but this also got failed create required shared libraries (.so)

5.I just simply want to add .so files in my Android app to play .mp2 files
because older version ffmpeg2.x not able play it on Nougat and oreo.

Please help me. Thanks in advance.

Sent from: http://www.ffmpeg-archive.org/

More information about the ffmpeg-user mailing list