[FFmpeg-user] ffmpeg git server misconfigured

Andrew Robinson andrew3 at r3dsolutions.com
Thu Feb 9 11:49:04 EET 2017


I have a slow internet connection with pay per megabyte.  I wanted to 
git clone a single branch of ffmpeg to save myself, and ffmpeg.org  
bandwidth costs.

I was able to look up the branches available:

     bash-4.3$ git ls-remote http://git.ffmpeg.org/ffmpeg
     cfff8a663c2746f6aae3e102e562dcb46280381d        refs/tags/n3.2.1
     7facc70ee9483ca49d0dd114f387716cd46cefd5        refs/tags/n3.2.2
     b4c2500cd2c92e9c1cf2fac293723bf11c696e0d        refs/tags/n3.2.3

So, I know git is working.  But, when I tried to download a branch with 
shallow copy .... the command fails.

    bash-4.3$  git clone --depth=1 --branch "n3.2.2" --single-branch 
http://git.ffmpeg.org/ffmpeg ffmpeg

    Cloning into 'ffmpeg'...
    fatal: The remote end hung up unexpectedly
    fatal: protocol error: bad pack header

I upgraded my git tools, and it still fails.
When I try a shallow branch copy for other software, it works. The mode 
is just broken with the ffmpeg site.
The ffmpeg site only allows a full clone, which is a very large file 

I did a lot of googling; apparently the bug is in recent versions of git 
where the *server* side program does not have enough memory, and tries 
to write a temporary file.
eg: it's misconfigured.  if the ramdrive or temporary drive has the 
wrong permissions; the server crashes and the client gets the error 
message I am receiving.

I tried to register with ffmpeg in order to make a bug report, but the 
system captcha failed and I was blacklisted as a spammer.
That's very annoying.

If anyone cares about the ffmpeg's costs in hosting git, would you mind 
trying to clone using --depth=1  and see if you get the same error as I do?
If you do, would you mind telling the appropriate system administrator 
their server has a problem.


More information about the ffmpeg-user mailing list