[FFmpeg-user] Streaming Syntax error

Moritz Barsnick barsnick at gmx.net
Mon Jul 24 12:16:45 EEST 2017

On Mon, Jul 24, 2017 at 09:30:38 +0530, Mettavihari D wrote:
> when I run this on the command line it is working.
> When I run this in a script I get errors.

Apparently, you use a differently built ffmpeg in the script.

> --enable-libvorbis --enable-libvpx --enable-libx264
> [NULL @ 0x3ca53a0] Unable to find a suitable output format for 'libx264'
> libx264: Invalid argument
> A hint on where to read more on this is very useful.

Though your ffmpeg's configure command line told it to build with
libx264, that apparently didn't work, and this ffmpeg doesn't support
libx264. (You can double-check with "ffmpeg -encoders".)

Can you not use the same ffmpeg as you use "on the command line" for
your script?

Otherwise, you need to rebuild that ffmpeg which is called from the
script in presence of the "libx264-devel" package, or you need to build
libx264 yourself beforehand, and make sure it is found while
configuring, see this section of the RedHat compilation guide:

Hope this helps,

More information about the ffmpeg-user mailing list