[FFmpeg-user] zmq filter setup

Moritz Barsnick barsnick at gmx.net
Tue Oct 17 17:04:07 EEST 2017

On Sun, Oct 15, 2017 at 18:45:48 -0400, kamal shadi wrote:
> Here's my installation:
> ffmpeg version 3.3.4 Copyright (c) 2000-2017 the FFmpeg developers
> I solved the issue using brew installation on mac.

So now you have the zmq filter available, right?

> Now I need to change the red parameters using zmq. Therefore I re-write
> above as:

On the mailing list, I don't see any colors. Have a look at this:


> \[tmp1][upperright] overlay=shortest=0:x=320 [tmp2]; \**[tmp2] *
> *[lowerleft] overlay=shortest=0:y=180 [tmp3]; \[lowerright]
> zmq, [tmp3] overlay=shortest=0:x=320:y=180" \-c:v libx264 output.mov*

Am I right in saying that you are only inserting the zmq filter into
the lowerright/tmp3 term?

So, does the ffmpeg command show any warnings or errors?

> *But I cannot get access to these parameters using zmqsend? I tried
> different messages like:*
> echo Parsed_overlay_0 x 440 | zmqsend
> echo Parsed_overlay_1 x 440 | zmqsend

Did these show any warnings or errors?

If you run your ffmpeg command with the option "-loglevel debug", the
filter chain(s) will show you the names of the filters. I believe your issue
is that you are using the incorrect names, as my log output shows me

> I appreciate your helps in advance,


More information about the ffmpeg-user mailing list