[FFmpeg-user] Audio filter: removesilence doesn't appear to do anything

Quinn Wood mtcjayne at gmail.com
Mon Sep 25 12:39:22 EEST 2017

I have removed the video and am getting the same results.
silenceremove is not removing silence.

  ffmpeg -i ../2017-09-24T123913.mp4.done -vn -af
silenceremove=0:0:0:-1:0.5:-20dB:1 output.m4a


  ffprobe -i output.m4a


  ffmpeg -i output.m4a -af silencedetect=n=-20dB:d=0.5 -f null -


Using peak detection makes no difference:
https://pastebin.com/raw/KwqXudSw https://pastebin.com/raw/462yRwQ7

On Mon, Sep 25, 2017 at 1:45 AM, Quinn Wood <mtcjayne at gmail.com> wrote:
> I thought I'd extracted the video by simply using the m4a extension-
> that's not the way that works and I should have noticed that. I bet
> the audio has been truncated but the video remains the full length.
> Let me strip out the video and try it.
> On Mon, Sep 25, 2017 at 12:59 AM, Quinn Wood <mtcjayne at gmail.com> wrote:
>> I have used the following command
>>     ffmpeg -i input.m4a -af silenceremove=0:0:0:-1:0.5:-20dB output.m4a
>> on a file. When I use another tool (Audacity) to truncate periods over
>> 0.5 seconds of under -20dB volume it removes upwards of an hour from
>> the input file. When I run this command ffmpeg doesn't remove a single
>> second. I have tried numerous variations of the command and numerous
>> input files, and am simply unable to replicate the effect Audacity is
>> producing.
>> The input files have a period of silence at the beginning that is
>> predictable, intermittent periods of silence throughout the file of
>> unknown quantity and length, and a period of silence at the end that
>> is predictable.

More information about the ffmpeg-user mailing list