[FFmpeg-user] ffmpeg named pipe

Kirk Liberty kirk.liberty at gmail.com
Fri Aug 3 09:14:18 EEST 2018

On Fri, Aug 3, 2018 at 1:46 AM, Zixia Huang <zixia.huang at gmail.com> wrote:
> Thanks Bob and Andrew.
> We are running ffmpeg in sandbox which blocks network connection. Also this
> is a docker machine in the commercial cloud, so stdin may not be accessible
> (I am not sure though, never tried).
> So looks like there is a rtbufsize flag in ffmpeg that buffers ingress
> video. So I assume that will hold large volumes of data?

I don't think rtbufsize works that way. I just tried...

mkfifo fifo
ffmpeg -i fifo -rtbufsize 1000M -c:v libx265 -crf 4 -threads 1 -preset
placebo delete.mkv
# In another window
cat 4k.mp4 | pv -nb > fifo

...and it loaded about 10 megabytes or 70 frames. Without rtbufsize
it's the same. And, whether or not it means anything I don't know, but
it was also about 10 megabytes or 70 frames with libx264.

Regardless, it is probably not going to cache bytes but whole frames,
which may be function of which codec you are using.


More information about the ffmpeg-user mailing list