[FFmpeg-user] Error Message not Understood - Help Please

Budge ajebay at errichel.co.uk
Mon Jul 2 18:57:34 EEST 2018

Running OpenSUSE Leap 42.3 and ffmpeg 3.4.2 and showing my ignorance here:

I have a downloaded file which plays on VLC or SMPlayer but will not 
play on a Linn DS device and tends to crash my android control point 
BubbleDS Next.

I had a similar issue a while ago which I eventually guessed was due to 
moov atom not being at the start of the file.  Running qt-faststart 
fixed this, the file then played OK and at that time I looked no further.

Now I have a bunch of files with similar problem.  I had forgotten about 
the moov atom issue and first tried to clean up the files using ffmpeg. 
This gave me the error messages I need help with (and a zero sized 
output file!)

If I run AtomicParsley I also get a segmentation fault reported.
I read through my previous notes and found the moov atom issue and, as 
before, putting this at the front of the file fixed the problem but I 
really would like to understand what I should be doing to clean up these 
files correctly so I do not get the error messages.

Here is the result of running ffmpeg:-

@ibmserver2:~/Working/remuxing> ffmpeg -i 
-c copy 
ffmpeg version 3.4.2 Copyright (c) 2000-2018 the FFmpeg developers
   built with gcc 4.8 (SUSE Linux)
   configuration: --prefix=/usr --libdir=/usr/lib64 
--shlibdir=/usr/lib64 --incdir=/usr/include/ffmpeg 
--extra-cflags='-fmessage-length=0 -grecord-gcc-switches -O2 -Wall 
-D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables 
-fasynchronous-unwind-tables -fstack-clash-protection -g' 
--optflags='-fmessage-length=0 -grecord-gcc-switches -O2 -Wall 
-D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables 
-fasynchronous-unwind-tables -fstack-clash-protection -g' 
--disable-htmlpages --enable-pic --disable-stripping --enable-shared 
--disable-static --enable-gpl --disable-openssl --enable-avresample 
--enable-libcdio --enable-gnutls --enable-ladspa --enable-libass 
--enable-libbluray --enable-libcelt --enable-libcdio --enable-libdc1394 
--enable-libfreetype --enable-libgsm --enable-libmp3lame 
--enable-libopenjpeg --enable-libopus --enable-libpulse 
--enable-libspeex --enable-libtheora --enable-libtwolame 
--enable-libvorbis --enable-libvpx --enable-libwebp --enable-libzvbi 
--enable-vaapi --enable-vdpau --enable-libfdk_aac --enable-nonfree 
--enable-libx264 --enable-libx265 --enable-libxvid
   libavutil      55. 78.100 / 55. 78.100
   libavcodec     57.107.100 / 57.107.100
   libavformat    57. 83.100 / 57. 83.100
   libavdevice    57. 10.100 / 57. 10.100
   libavfilter     6.107.100 /  6.107.100
   libavresample   3.  7.  0 /  3.  7.  0
   libswscale      4.  8.100 /  4.  8.100
   libswresample   2.  9.100 /  2.  9.100
   libpostproc    54.  7.100 / 54.  7.100
[mov,mp4,m4a,3gp,3g2,mj2 @ 0xb02180] stream 0, timescale not set
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 
     major_brand     : M4A
     minor_version   : 512
     compatible_brands: isomiso2
     creation_time   : 1970-01-01T00:00:00.000000Z
     encoder         : Lavf53.24.2
     media_type      : 1
     copyright       : � 2012 British Broadcasting Corporation, all 
rights reserved
     title           : Claudio Monteverdi  (1567-1643): Episode 1
     artist          : BBC Radio 3
     album_artist    : BBC Radio
     album           : Composer of the Week
     grouping        : Factual,Arts, Culture & the Media,Music,Classical
     composer        : BBC iPlayer
     genre           : Factual
     comment         : Donald Macleod discusses Monteverdi's musical 
obsession with sex and violence.
     date            : 2011
     track           : 1
     lyrics          : Donald Macleod follows Monteverdi on the road to 
stardom at the court of Mantua and uncovers, in this first programme, a 
musical obsession with sex and violence.
                     : EPISODE
                     : SERIES
                     :   http://www.bbc.co.uk/programmes/b00zm2rd.html
     disc            : 0
   Duration: 02:59:00.37, start: 0.000000, bitrate: 322 kb/s
     Stream #0:0(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, 
stereo, fltp, 319 kb/s (default)
       creation_time   : 1970-01-01T00:00:00.000000Z
       handler_name    : SoundHandler
     Stream #0:1: Video: mjpeg, yuvj444p(pc, bt470bg/unknown/unknown), 
150x84 [SAR 100:100 DAR 25:14], 90k tbr, 90k tbn, 90k tbc
[ipod @ 0xbb05e0] Could not find tag for codec mjpeg in stream #0, codec 
not currently supported in container
Could not write header for output file #0 (incorrect codec parameters 
?): Invalid argument
Stream mapping:
   Stream #0:1 -> #0:0 (copy)
   Stream #0:0 -> #0:1 (copy)
     Last message repeated 1 times

Grateful for some help when somebody had time please.

More information about the ffmpeg-user mailing list