[FFmpeg-user] ffmpeg sends I frame only when starting process

Federico Allegretti allegfede at gmail.com
Tue Jul 24 18:04:41 EEST 2018

hello everybody.

I'm trying to capture desktop of a raspbian pc (raspberry pi2) convert it
to h264 using omx hardware accelerated encoder, mux it with the audio from
an internet radio (original vorbis, encoded in aac) and send it to a remote
pc via UDP mpeg transport stream (i receive it trough vlc).

This is the command:
ffmpeg -video_size $RISOLUZIONE_video -f x11grab -i :0.0 -r 25 -i
$SORGENTE_audio_stream  -c:v h264_omx -b:v $BITRATE_video -c:a aac -b:a
$BITRATE_audio -ac 2 -ar 44100 -f mpegts -vbsf h264_mp4toannexb

the problem is that if i got VLC listening from a network stream at
udp://*:$MULTIPLEXER_port (usualli i run it on the 5000), it intercept the
correct video codec, video size, audio codec etc (and plays smooth)

but if i run the script and THEN i start vlc, it detects the audio codec
and data (i listen the audio), detects teh video codec, BUT do not detect
resolution NOR display any image ...

Seems quite go I frames where sent ater the ffmpeg process started.

PS: i compiled the omx accelerated ffmpeg from latest git using this guide:

PPS: strange that i have this in console output also if i set the rate
switch to 25 (-r 25):
frame= 1417 fps=6.2 q=-0.0 size=   13895kB time=00:03:46.25 bitrate=

Open TV Architecture project: http://sourceforge.net/projects/otva/

Messagenet VOIP: 5338759

YouTube Channel: v1p3r's lab

VIMEO HD videos: http://www.vimeo.com/user1912745/videos

More information about the ffmpeg-user mailing list