[FFmpeg-user] m3u8 live stream will not play in google chrome

Anthony Griffiths neuronetv at gmail.com
Thu Jul 26 11:46:20 EEST 2018

On Wed, Jul 25, 2018 at 1:36 PM, Moritz Barsnick <barsnick at gmx.net> wrote:
> On Wed, Jul 25, 2018 at 11:25:57 +0100, Anthony Griffiths wrote:
>> https://video-dev.github.io/hls.js/demo/
> Where's the m3u8 link in there?

theres a think blue horizontal line with the text 'Select a test stream....'
immediately under that there's an url which plays a big buck bunny
cartoon. You can delete the url and substitute another. (mine)
> Have you tried using other mime types?
> Someone here:
> https://stackoverflow.com/q/6438680/3974309
> uses this:
> AddType application/x-mpegURL .m3u8
> AddType video/MP2T .ts
> While you use
> application/vnd.apple.mpegurl
> application/octet-stream

thanks I tried
AddType application/x-mpegURL .m3u8
> AddType video/MP2T .ts

but it made no difference, the video still will not play in google chrome.
I'm convinced the problem is with google chrome and flash player. My
ffmpeg command incorporates 'f -flv' and google chrome doesn't like
this. I've also tried 'f -mpegts' and 'f -mpeg', the command runs ok
but there's video in anything. I need to substitute 'f -flv' with
something else but i don't know what.

More information about the ffmpeg-user mailing list