[FFmpeg-user] ffnvcodec dependency not satisfied even after including external headers

Danny Darvish darvish at cmu.edu
Sat Mar 31 00:26:04 EEST 2018


I think configure made a mistake when giving me this error, because the
dependency *should* be satisfied:

*        ERROR: cuda requested, but not all dependencies are satisfied:
I have downloaded the Nvidia headers from the repository here:

*        https://git.videolan.org/git/ffmpeg/nv-codec-headers.git
And run make & make install. Make install puts ffnvcodec.pc in
/usr/local/lib/pkgconfig/, which is listed when I run:

*        pkg-config --variable pc_path pkg-config*
PKG_CONFIG_PATH was not set by default, but I exported the output of the
above command to PKG_CONFIG_PATH.

None of this has worked though. I am on macOS. I have attached my
config.log file.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 518072 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-user/attachments/20180330/4461986f/attachment.obj>

More information about the ffmpeg-user mailing list