[FFmpeg-user] ffmpeg hang in background

sailor-godkane jimmy at dcode.eu
Wed Oct 10 16:37:29 EEST 2018


I am using ffmpeg in a big project for video/audio automated processing.
Each project for processing requires lots of ffmpeg commands. Those commands
are run by a daemon written in ObjC using GnuStep.
Since it runs on the background i used -nostdin and -loglevel quiet for
production use.
To be sure i read everything on stdout and stderr to /dev/null but it should
not matter since the command does not output anything.
Everything run fine except sometimes a ffmpeg command will hang and i cannot
understand why.
Sometimes i can see a few % of cpu used by the commands but after hours it
was still there.
When it happens i have to shutdown my daemon and restart the processing. The
same command will then run fine and the process can be finished.

Details of ffmpeg (compiled from source)

ffmpeg version n4.0.2 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 4.8 (SUSE Linux)
  configuration: --disable-programs --enable-ffprobe --enable-ffmpeg
--enable-libx264 --enable-gpl --enable-shared --enable-pthreads
--enable-libmp3lame --enable-pic
  libavutil      56. 14.100 / 56. 14.100
  libavcodec     58. 18.100 / 58. 18.100
  libavformat    58. 12.100 / 58. 12.100
  libavdevice    58.  3.100 / 58.  3.100
  libavfilter     7. 16.100 /  7. 16.100
  libswscale      5.  1.100 /  5.  1.100
  libswresample   3.  1.100 /  3.  1.100
  libpostproc    55.  1.100 / 55.  1.100

System is :

openSUSE 13.1 - 3.11.10-29-desktop

The machine is a virtual one running on VMWare.

The command that most often hangs is 

ffmpeg -nostdin -loglevel quiet -y -i front_slide_video.mov -an -r 16.000000
-c:v libx264 -preset slow -b:v 5000k -aspect 1.333333 -vf
scale=640:480,pad=640:480:0:0:black front_slide_video-rescaled.mov

But i had other commands hanging randomly as well so this is just a sample.

Since this is completely random i have no way of testing it. The command
that hang works fine if i run it manually and it runs fine most of the time
when the daemon runs it.
I upgraded from a version 2.X that was running on the previous major version
of my software. It's been a few years since i worked on it but i don't
recall hangs back in the day with version 2.

I had the same problem with 4.0.1 btw.

Thanks for your help 

Sent from: http://www.ffmpeg-archive.org/

More information about the ffmpeg-user mailing list