[FFmpeg-user] ffprobe returns wrong bitrate on fragmented mp4

Moritz Barsnick barsnick at gmx.net
Mon Dec 2 15:17:28 EET 2019

On Mon, Dec 02, 2019 at 17:18:49 +1000, daniel jee wrote:
> I tried running ffprobe on a fragmented mp4 file with a bunch of moof +
> mdat boxes.
> The command that I tried was: ffprobe -show_streams -show_format ./video.mp4
> The output was as follows:
> ffprobe version 3.4.6-0ubuntu0.18.04.1 Copyright (c) 2007-2019 the FFmpeg developers

This version is functionally over two years old. Could you kindly try a
very recent version from git master? Your issue may have been fixed.

(You can grab a static binary, if you don't care to compile yourself,
Left column, git master, please.)

>   Duration: 00:04:48.04, start: 0.000000, bitrate: 1578 kb/s
>     Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p(tv, bt709, progressive), 1280x720 [SAR 1:1 DAR 16:9], 32 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)
> bit_rate=32993
> bit_rate=1578642

Which of the three mentioned ones do you consider incorrect?


More information about the ffmpeg-user mailing list