[FFmpeg-user] Timestamps are unset

Tom Worton mtomworton at hotmail.com
Sun Feb 24 11:10:10 EET 2019

I hope that I am doing this right, the format of sending emails is a little different then posting on other forums that I have reached out to in the past. I have been using ffmpeg for only a short period of time and while it has worked great, I am running into an issue and need a little assistance.  I have been moving my movies to a drive and then I will stream to the TV's in the house.  Unfortunately due to the devices that I am streaming the movies with,  I am limited to AC3 and not True HD or even DTS.  So I have been converting all of the audio in my movies to AC3 with ffmpeg.  Below is the command that I have been using

ffmpeg.exe -i myvideofile.mkv -map 0 -vcodec copy -scodec copy -acodec ac3 -b:a 640k myvideofilewithAC3.mkv

As I said this has worked great for nearly all of my movies, but I am getting an error with several of them.  The error reads "Time stamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your time code to set the timestamp properly."

While I am pretty new to this, I am confused as I am coping the video with no changes and yet there are issues.  I am also confused as to why most of my movies not have any problems, but a several do? Most important question is how do I fix this.  I have searched online and I haven't found anything that helps.



More information about the ffmpeg-user mailing list