[FFmpeg-user] Time-lapse generation

Moritz Barsnick barsnick at gmx.net
Fri Oct 25 12:35:47 EEST 2019

On Fri, Oct 25, 2019 at 10:59:27 +0200, MailingLists - XYZ via ffmpeg-user wrote:
> 	ffmpeg -f image2 -r 5 -pattern_type glob -i '*[0-9].jpg' -vf "scale=1620:1080,format=yuv420p" -vcodec libx264 final.mp4

"-framerate" is preferred over "-r".

> Starting around the 8000th picture, ffmpeg started dropping frames and the behaviour continued up until the end of the file.

You should show us the complete, uncut console output of your command.

> My question is : how could I ask ffmpeg to not be bothered by the
> pictures resolution changes and scale them according to the output
> dimension, 1620:1080, even though input images might be smaller than
> that ?

The command should be correct to achieve that.

> Following advice on Stack Overflow, I tried to modify the output
> scale with "scale=1620:-2” instead of "scale=1620:1080” but nothing
> changed, frames continued to be dropped…

Well, that's stupid advice, as 1080 is already divisible by 2.

> (I’m using ffmpeg 3.2.14 and I haven’t tried a newer version)

That's certainly not sufficient. What if this was fixed in the
meantime? Kindly grab a newer version. E.g. for Linux, this site
provides static builds:
(Left column, "git master", please.)

Please do try that first, and come back with the results (including the
console output).


More information about the ffmpeg-user mailing list