[FFmpeg-user] Compiled ffmpeg - x264 - instability when using -pix_fmt yuv420p

Jonathan Niquet jniquet at rodeofx.com
Thu Sep 12 21:40:04 EEST 2019

Hey there,

We've been using John Van Sickle's ffmpeg static build for quite a while
and it's worked wonderfully for us.

However, we recently had to incorporate aac into our build.

I then started to statically compile every library we needed and proceed to
successfully build FFmpeg.

This is on Linux, centos 7.6.
This was my config arguments:

--prefix="/home/jon/ffmpegBuild" --extra-libs="-lpthread -lm -fopenmp"
--enable-gpl --enable-version3 --enable-nonfree
--pkg-config-flags="--static" --enable-static --disable-shared
--enable-debug --disable-ffplay --disable-indev=sndio
--disable-outdev=sndio --enable-libfdk-aac --enable-frei0r --enable-libaom
--enable-libfribidi  --enable-libass --enable-libvpx --enable-libx264
--enable-libwebp --enable-libxml2 --enable-fontconfig --enable-gray
--enable-libfreetype --enable-libzvbi --enable-libvidstab --enable-libvmaf
--enable-libvorbis --enable-libmp3lame --enable-libopus
--enable-libopenjpeg --enable-libzimg --enable-libspeex --enable-libx265
--enable-gmp --enable-libvo-amrwbenc --enable-libopencore-amrwb
--enable-libopencore-amrnb --enable-libsoxr --enable-libxvid

However, in a random fashion, whenever we use "*-pix_fmt yuv420p*" when
encoding libx264
(*-c:v libx264 -c:a copy -crf 20 -pix_fmt yuv420p -vf
colormatrix=bt601:bt709*), FFmpeg will randomly segfault between 40% to 45%
of the time. Using the same command 20 times in a row, on the same
computer, will literally give 11 completion and 9 segfaults. I've tried
recompiling the whole things on a virtual machine specially setup for this
task (blank, minimal install) and the exact same behavior is observed.

I've tried to strace the process, I didn't notice anything that sounds like
a solution.
>From John's static build, I only removed 3 libraries: gnutls, librubberband
and libtheora.

I'm thinking it might be a problem with my x264 compilation, the randomness
of the things might point to threading issues, but I'm not too sure what to
look at at this point.

Anyone experienced something similar before or would have clues to help me
debug this hellish instability?

[image: RODEO FX] <https://www.rodeofx.com/>
[image: Facebook] <https://www.facebook.com/rodeofx/> [image: Twitter]
<https://twitter.com/FXRodeo> [image: LinkedIn]
<https://www.linkedin.com/company/251532/admin/> [image: Vimeo]
<https://vimeo.com/rodeofx> [image: Instagram]
*Jonathan Niquet <https://ca.linkedin.com/in/jonathan-niquet-62b37239>*
Application Support Specialist
*jniquet at rodeofx.com <jniquet at rodeofx.com> *
514.397.9999 ext.599
*www.rodeofx.com <https://www.rodeofx.com/>*

More information about the ffmpeg-user mailing list