[FFmpeg-user] Streaming wav sound with FFMPEG

Moritz Barsnick barsnick at gmx.net
Wed Jun 17 17:54:14 EEST 2020

Hi Nicolas,

On Wed, Jun 17, 2020 at 11:37:00 +0200, Nicolas VAMBAIRGUE wrote:
> So I tried the couple :
>      ffmpeg -i -acodec pcm_s16le -ar 44100 -ac
> 2 -f rtp -sdp_file /home/dr_click/audio.sdp rtp://
> and
>      ffplay /home/dr_click/audio.sdp
> I got the following error :
> - [rtp @ 0x7f7d00008040] Protocol 'rtp' not on whitelist 'file,crypto'! if
> And if I finally tried :
>      fmpeg -protocol_whitelist file,http,rtp,tcp -i
> -acodec pcm_s16le -ar 44100 -ac 2 -f rtp
> -sdp_file /home/dr_click/audio.sdp rtp://
> But I get the same "whitelist" error.

(As Carl Eugen wrote, please also show the complete, uncut console

The "Protocol 'rtp' not on whitelist" was an ffplay error, so you need
to add those options to the client ffplay command line, not to the
server's. (You may also need the protocol "udp".)

I can reproduce your error. If I add that option (plus "udp") to
ffplay, the error goes away. I get a different issue then, but YMMV.


More information about the ffmpeg-user mailing list