[FFmpeg-user] build error at libavformat/udp.o

Hyoung Kim hyoungtaik at yahoo.com
Tue Sep 1 05:08:35 EEST 2020


Thanks for your response.

1. You are right.
The error message with the git head in my previous email looked like
an encoding issue. So I have done git clone at ubuntu 18.01 again and I got the same error message I had
for FFmpeg 4.3.1 like followings :

src/libavformat/udp.c:296:28: error: member reference base type
'__be32' (aka 'unsigned int') is not a structure or union
mreqs.imr_multiaddr.s_addr = ((struct sockaddr_in *)add...
src/libavformat/udp.c:298:32: error: assigning to '__be32'
(aka 'unsigned int') from incompatible type 'struct in_addr'
...= ((struct sockaddr_in *)local_addr)->sin_addr;
^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
src/libavformat/udp.c:300:32: error: member reference base type
'__be32' (aka 'unsigned int') is not a structure or union
mreqs.imr_interface.s_addr= INADDR_ANY;
src/libavformat/udp.c:301:29: error: member reference base type
'__be32' (aka 'unsigned int') is not a structure or union
mreqs.imr_sourceaddr.s_addr = ((struct sockaddr_in *)&s...
4 errors generated.

2. I have attached the first part of log, when I have tried to build the FFmpeg at the end of this email.

3. When I tried to use FFmpeg 4.0.6, I do not have any problem to build it. I have even done simple smoke test successfully for our final product.

Thanks in any case.
     On Monday, August 31, 2020, 09:28:21 PM EDT, Ted Park <kumowoon1025 at gmail.com> wrote:  

 I will try to explain one step at a time.

Can you explain one step at a time, as in explain the steps you took (one
command line at a time)? Maybe it’s because I’ve never cross compiled
ffmpeg but your mentioning cmake makes me think you are messing up the
build system. Like there’s no info about your c environment.

 3. build error message, when I have used git head :
>  /ffmpeg/configure: /bin/sh^M: bad interpreter: No such file or directory

Did you do anything after checking out the repository before running
configure (except cd’ing into the directory)? That carriage return I think
I’ve seen when a super long list of arguments were given but probably the
issue is something else.

ffmpeg-user mailing list
ffmpeg-user at ffmpeg.org

To unsubscribe, visit link above, or email
ffmpeg-user-request at ffmpeg.org with subject "unsubscribe".  
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: hk89.txt
URL: <https://ffmpeg.org/pipermail/ffmpeg-user/attachments/20200901/e82f21af/attachment.txt>

More information about the ffmpeg-user mailing list