[FFmpeg-user] Unable to play or import video files in an app that uses ffmpeg

Tim Stiles tim.stiles79 at gmail.com
Wed Sep 9 18:45:58 EEST 2020

> > > The first log entry appears to show how the app called FFprobe. You
> > > could try to run that same command yourself from the Command Prompt…
> > [Tim] Here is the command line output of both tests one after the other…
> >
> > C:\Users\Tim
> > -v error -show_format -show_streams -print_format xml "C:\Users\Tim
> > Stiles\AppData\Local\Temp\pbi2.mp4"
> > <?xml version="1.0" encoding="UTF-8"?>
> > <ffprobe>
> >      <streams>
> >          …snip…
> >      </streams>
> >
> >      <format filename=  …snip…
> >      </format>
> > </ffprobe>

> What this seems to show is that FFprobe is installed, and runs
> correctly, giving reasonable output. That makes it more likely that the
> log entries you posted are noting a successful run of FFprobe, instead
> of a failed run.  I think that puts the ball back in the PinballBrowser
> court. Is it getting the same result when it calls FFprobe?  And that is
> a question for them, not for this list.

Thank you! I will follow up again with the PB dev and see what he has to

> > > Issue: For me specifically on my Windows 10 PC, these video playback
> and
> > > import features do not work. When I select a video to play, nothing
> happens
> > > (the app is supposed to have an inner window that displays the
> playback but
> > > that is non-existent when I hit play).
> > Perhaps some differential diagnosis could be helpful. It sounds like the
> program worked, and you used it successfully at some point, what has
> changed? Which operating system did you run before?
> Actually I don't think these features of the program ever worked for me,
on this Windows PC having the issue. My version of Windows 10 is kept up to
date. I unfortunately don't have a different PC to use and PB is only
supported for Windows/PC.
So,when you download the app those 3 .exe's are not included. You need to
go download them and copy them to the root Pinball Browser folder. Early
on, I didn't realize it was that simple. And I think I may have gone
overboard and "installed" the entire FFmpeg library/package. Could that
have been a bad idea? I feel like I would have gone and uninstalled any of
that once I realized but I'm not quite sure. When I look around I cannot
find any ffmpeg in programs and features. I only find these executables in
the PB directory. Is it possible that a bad version of ffmpeg is lurking on
my machine and conflicting with the "successful uses" by Pinball Browser or
my command line tests? Probably a stretch.
I guess beyond that, I'm curious if there are any other apps, drivers,
video cards, etc. specific to my PC that are known to cause issues with
ffmpeg in general? I have an Nvidia GE Force video card and am running
Nvidia's drivers. Pinball Browser is the only app that supports video
playback or import that I have any issues with though.. Thoughts?

More information about the ffmpeg-user mailing list