[FFmpeg-user] 5% of audio samples missing when capturing audio on a mac

Edward Park kumowoon1025 at gmail.com
Sat Sep 12 21:24:22 EEST 2020


You know it's confounding, I couldn't get avfoundation audio input to work at all, and then tried a bunch of options to get to the weird issue you describe (which I thought was maybe something to do with the clock source being different) but then I went back to supplying no extraneous options and it works pretty much without issue... In my case I was trying with a turntable plugged into an external interface, with ffplay I'm using to listen through my Mac seeing if it'll start stuttering again (???)

Some things I tried before it started working apparently on its own is explicitly setting decoder to pcm_f32le and setting input sample rates lower. Expectedly, it messes with pitch if you do this, but what I did not understand is it wasn't consistent, kept speeding up and back down. (And I'm sure it wasn't the spindle on the turntable)

I have no idea, other than that I think it's probably some other sound application changing system sound servers configuration with no relation to what I'm doing with ffmpeg...

Ted Park

More information about the ffmpeg-user mailing list