[FFmpeg-user] Data Metadata Tag lost in Conversion

Tim McClure tjmcclure0501 at gmail.com
Thu Sep 17 00:51:29 EEST 2020

ffmpeg -i rtsp:// -map 0:1 -pix_fmt yuv420p -vcodec
libx264 -r 25 -vf scale=1024:576 -threads 0 -b:v: 2048k -bufsize 2244k
-maxrate 2560k -preset veryfast -profile:v baseline -tune zerolatency -g 100
-x264opts no-scenecut -f mpegts
udp://fhp22-wowza.strax.co:5001?pkt_size=1316 -map 0:0 -codec copy -f mpegts

I am using the following script to split the video and data streams from a
mpegts formatted file being received through an RTSP link.  When I run
ffprobe on the rtsp feed I get told that stream 0 is:
     Stream #0:0[0x100]: Data: klv (KLVA / 0x41564C4B)

I use the following ffmpeg script to read the input file:
ffmpeg -i udp://localhost:9001 -c copy -map 0:0 -f data ./klv.txt

This just hangs and never processes the data - I see the data coming into
the 9001 port using tcpdump.  When I run ffprobe on the data stream coming
in it just hangs - no metadata info is displayed.

It appears the metadata stream type info is getting lost on the splitting of
the RTSP stream into 2 separate udp streams however the video stream works
fine.  I need to be able to either set the metadata type of the data stream
in the script that sends the data stream or on the script that reads the
stream - does anyone know how to do this?


Sent from: http://www.ffmpeg-archive.org/

More information about the ffmpeg-user mailing list