[FFmpeg-user] issues in ffmpeg installation

Vemula, Saibharath Saibharath.Vemula at netapp.com
Thu Apr 14 05:57:02 EEST 2022

Hi Team,

I have CentOS Stream 8  vm which has 50 gb space and i have tried the below steps for installing ffmpeg on the the vm by following steps present in the link

  *   https://developer.nvidia.com/blog/nvidia-ffmpeg-transcoding-guide/
1.Downloaded repository "https://git.ffmpeg.org/ffmpeg.git and cloned with

  *   git clone https://git.ffmpeg.org/ffmpeg.git"
2.Downaloded the nvidia driver for tesla T4 product and linux 64-bit RHEL 8
file name is "nvidia-driver-local-repo-rhel8-510.47.03-1.0-1.x86_64.rpm"
3.Downloaded the cuda tool kit for centos 8 system by running following commands

  *   wget https://developer.download.nvidia.com/compute/cuda/11.6.2/local_installers/cuda-repo-rhel8-11-6-local-11.6.2_510.47.03-1.x86_64.rpm
  *   sudo rpm -i cuda-repo-rhel8-11-6-local-11.6.2_510.47.03-1.x86_64.rpm
  *   sudo dnf clean all
  *   sudo dnf -y module install nvidia-driver:latest-dkms
  *   sudo dnf -y install cuda

4.cloned the rep FFmpeg/nv-codec-headers

  *   git clone https://git.videolan.org/git/ffmpeg/nv-codec-headers.git

5.After completion of ffmpeg/nv-codec-headers,i have entered to the nv-codec-headers folder

  *   cd nv-codec-headers
6.i'm getting below installation messages when i ran the "make install" command and kindly help me in resolving the issue
[root at localhost nv-codec-headers]# make install
sed 's#@@PREFIX@@#/usr/local#' ffnvcodec.pc.in > ffnvcodec.pc
install -m 0755 -d '/usr/local/include/ffnvcodec'
install -m 0644 include/ffnvcodec/*.h '/usr/local/include/ffnvcodec'
install -m 0755 -d '/usr/local/lib/pkgconfig'
install -m 0644 ffnvcodec.pc '/usr/local/lib/pkgconfig'


More information about the ffmpeg-user mailing list