[FFmpeg-user] configure gives "ERROR: libzmq >= 4.2.1 not found using pkg-config"

Thomas Seilund tps.ffmpeg at netmaster.dk
Wed Feb 23 13:24:19 EET 2022

Hi All

I get this message when I run configure.sh "ERROR: libzmq >= 4.2.1 not 
found using pkg-config"

I run these two commands to check that I have libzmq:

ldconfig -p | grep libzmq
         libzmq.so.5 (libc6,AArch64) => /lib/aarch64-linux-gnu/libzmq.so.5
         libzmq.so (libc6,AArch64) => /lib/aarch64-linux-gnu/libzmq.so

apt list --installed | grep libzmq

WARNING: apt does not have a stable CLI interface. Use with caution in 

libzmq3-dev/stable,now 4.3.4-1 arm64 [installed]
libzmq5/stable,now 4.3.4-1 arm64 [installed,automatic]

Here is the full ./configure command

./configure --prefix=/home/pi/ffmpeg_build \
--pkg-config-flags=--static \
--extra-cflags=-I/home/pi/ffmpeg_build/include \
--extra-ldflags=-L/home/pi/ffmpeg_build/lib \
--extra-libs='-lpthread -lm' \
--ld=g++ \
--bindir=/home/pi/bin \
--enable-gpl \
--enable-gnutls \
--enable-libfdk-aac \
--enable-libfreetype \
--enable-libx264 \
--enable-libzmq \

I guess that when I get an error using ./configure it does not make any 
sense to compile.


Thomas S

More information about the ffmpeg-user mailing list