[FFmpeg-user] ffmpeg problem: Wrong or missing size information for certain EXRs

Kevin Steele kevwsteele at gmail.com
Tue Sep 20 17:37:32 EEST 2022

Hi! I am trying to convert EXRs to a quicktime video. It has worked several
times for me in the past. However, sometimes it doesn't work mysteriously
on certain exrs and I am not clear why.
Below is a google drive link to the exr file as an example; I assume people
may need to reproduce this. The file is too big to include in an email. The
EXR opens fine for me in various programs.
I have tested this on both my mac and windows and I get the issue on both
platforms. I am using a new version of ffmpeg from 2022.
The command I tried is below:

ffmpeg -analyzeduration 9223372036854775807 -probesize 9223372036854775807
-s 1280x720 -i Window_v001.1001.exr -codec:v libx264 -s
1280x720  Window_v001.mov

Below are things I have already tried, as you can tell from my
command above:

 - setting analyzeduration and probesize to highest possible values

- forcing the size

- I have also tried various codecs.

This exr was rendered from a program called 3ds Max: I'm not sure if that
matters. However, often fmmpeg works totally fine with exrs rendered from
3ds. It just mysteriously fails sometimes.

Anyone have any ideas/suggestions? Thanks so much

More information about the ffmpeg-user mailing list