[FFmpeg-user] ebuR128 display of live source

Moritz Barsnick barsnick at gmx.net
Thu Mar 16 18:39:05 EET 2023

On Fri, Mar 03, 2023 at 12:31:40 +0100, Bouke / Videotoolshed wrote:
> > On 1 Mar 2023, at 11:53, Bouke / Videotoolshed <bouke at videotoolshed.com> wrote:
> > Trying to get a visualisation of my levels during record / stream.
> > This works fine for file based material:
> > ffplay -f lavfi -i "amovie=/Users/bouke/Downloads/test.wav,ebur128=video=1:meter=18:target=-16 [out0][out1]"
> > But I would like to have a live source (I’m on Mac, AVfoundation I guess.)
> Tried the following:
> ffplay -f lavfi -i "amovie='\:2':f=avfoundation,ebur128=video=1:meter=18:target=-16 [out0][out1]”
> Closer, but still no cigar:
> It does not throw an error, but nothing is shown, as if input is not fed to the ebur128 filter

Are you sure your avfoundation device delivers any audio packets into
the filter chain?

Have you tried piping the device to stdout (e.g. in the nut container),
and then using a second process to do the ebur128 on stdin?

Just guessing here - I don't have avfoundation, nor have I tried with
ffplay. I only tried with anoisesrc and with a pipe to ffmpeg.


More information about the ffmpeg-user mailing list