[FFmpeg-user] To make a PTS, FFmpeg is truncating *up*

Mark Filipak markfilipak.imdb at gmail.com
Thu Feb 15 21:54:00 EET 2024

On 15/02/2024 13.55, Diederick C. Niehorster wrote:
> Hi Mark,
> On Thu, Feb 15, 2024, 19:42 Mark Filipak <markfilipak.imdb at gmail.com> wrote:
>> Here is my first finding.
>> Can someone who reads 'C' code locate the code and investigate?
> As told to you many times now, you need to provide a complete command line,
> with accessible input files, so that others can reproduce. Else no one can
> help investigate, should they wish to.

This is not an ordinary how-do-I-make-this-work issue. This is part of a long investigation.

Typical commands I've used are these:
ffmpeg -copyts -i this.m2ts -map 0 -bsf:v noise=drop='lt(pts\,2854113)+gt(pts\,504223732)' -bsf:a 
noise=drop='lt(pts\,2854113)+gt(pts\,504223732)' -bsf:s 
noise=drop='lt(pts\,2854113)+gt(pts\,504223732)' %CODE% -muxdelay 0 that.m2ts
-- which worked.
ffmpeg -copyts -i "concat:that1.m2ts|that2.m2ts" -map 0 -c copy -dn -muxdelay 0 that3.m2ts
-- which worked.

that3.m2ts has beautiful structure, like it was mastered as a single video, not joined from trims of 
two other videos. Except, it has a glitch. The glitch appears to result from bad PTSs.

I noticed that FFmpeg is truncating badly.

I don't know what I would post, or how. I have tons of material.

I need someone who has great knowledge of the source code to help me. Contact me directly and I'll 
share all I have.

I'll tell you one thing:
ffmpeg -ss <cut-time> -i this.m2ts -map 0 -c copy -sn -dn that.m2ts
is junk.


More information about the ffmpeg-user mailing list