[FFmpeg-user] abitscope won't run

Mark Filipak markfilipak.imdb at gmail.com
Mon May 20 22:22:40 EEST 2024

On 20/05/2024 14.09, Moritz Barsnick via ffmpeg-user wrote:
> On Mon, May 20, 2024 at 13:14:43 -0400, Mark Filipak wrote:
>> Doesn't work:
>> ffmpeg -i c:\source.mp4 -map 0 -af abitscope -c:v libx265 -x265-params
>> crf=18 -c:a ac3 -sn -dn "c:\abitscope.mp4"
> [...]
>> [vf#0:0 @ 000000000053e0c0] Tried to connect video stream to audio filtergraph input
> abitscope has a video output. You need to use a "-filter_complex"
> instead of "-af" to map its output to a video stream (and then of
> course map that stream into your output file).

Thanks, Moritz, but I don't know how to map a video stream that originates inside ffmpeg.
   -filter_complex "abitscope=r=24000/1001[a]" -map "[a]"
doesn't work. I've tried variations but they didn't work. They all say,
"Cannot find a matching stream for unlabeled input pad abitscope:default".

Can you give me a bigger 'push', eh?


More information about the ffmpeg-user mailing list