[Libav-user] get mpeg4 streams with rtsp protocol

luke lclemens at gmail.com
Wed Jun 15 23:38:05 CEST 2011

I'm having this same problem with two axis ip cameras and two panasonic ip
cameras!! The video gets messed up with ghosting and other artifacts,
especially in the lower half. The console spits out hundreds of errors each

To reproduce the error, go to: http://ffmpeg.zeranoe.com/builds/ and get the
latest 32 bit static build for, (the one I have is 1929807). Then open a IP
camera rtsp stream via ffplay. If you don't have one, I found one that's
accessible online that you can access using: 

ffplay rtsp:// 

There will be a lot of errors in the output console for ffplay.

A few years ago we used some older versions that didn't have any mpeg4
errors, but they had another problem that caused the video to timeout after
1 minute. So it seems like the timeout problem was fixed, but replaced by
this mpeg4 issue. There is a post in the ffmpeg group that describes the
same issue. And another one here:
http://web.archiveorange.com/archive/v/yR2T4qtfjQ1es89IeoVN .

It's not just ffplay either. I tried it with several example apps like the
ffmpeg sdl tutorial here: http://dranger.com/ffmpeg/ and my own code - they
all get the same mpeg4 errors. The common code for these apps is based on
av_open_input_file(), av_find_stream_info(), and av_read_frame().

I've tried it on several different windows computers. I'm going to try it on
Ubuntu tonight. 

Is there a chance that perhaps we just need a certain flag or option

I will look into the source code and see if I can find the bug, but I'm
pretty new with mpeg4 codec specifics so it would help a lot if someone can
give me a better idea of where to look. I don't even know where to begin -
the rtp parsing or the mpeg4 decompression?

BTW, the errors I'm getting look like: 

C:\ffmpeg\bin>ffplay rtsp:// 
ffplay version git-N-30344-g5501afa, Copyright (c) 2003-2011 the FFmpeg
  built on May 27 2011 22:37:57 with gcc 4.5.3 
  configuration: --enable-gpl --enable-version3 --enable-memalign-hack
runtime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r
pencore-amrnb --enable-libopencore-amrwb --enable-libfreetype
--enable-libgsm -- 
enable-libmp3lame --enable-libopenjpeg --enable-librtmp
 --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx
e-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil    51.  2. 2 / 51.  2. 2 
  libavcodec   53.  6. 0 / 53.  6. 0 
  libavformat  53.  2. 0 / 53.  2. 0 
  libavdevice  53.  0. 0 / 53.  0. 0 
  libavfilter   2. 11. 0 /  2. 11. 0 
  libswscale    0. 14. 0 /  0. 14. 0 
  libpostproc  51.  2. 0 / 51.  2. 0 
[rtsp @ 01E57B60] Estimating duration from bitrate, this may be inaccurate 
Input #0, rtsp, from 'rtsp://': 
    title           : Media Presentation 
  Duration: N/A, start: 0.030000, bitrate: N/A 
    Stream #0.0: Video: mpeg4, yuv420p, 352x288 [PAR 12:11 DAR 4:3], 100
tbr, 90 
k tbn, 100 tbc 
[mpeg4 @ 01E5BA40] ac-tex damaged at 16 4B vq=   17KB sq=    0B f=0/0 
[mpeg4 @ 01E5BA40] Error at MB: 108 
[mpeg4 @ 01E5BA40] concealing 44 DC, 44 AC, 44 MV errors 
[mpeg4 @ 01E5BA40] 1. marker bit missing in 3. esc=    0B f=0/0 
[mpeg4 @ 01E5BA40] Error at MB: 61 
[mpeg4 @ 01E5BA40] concealing 110 DC, 110 AC, 110 MV errors 
[mpeg4 @ 01E5BA40] concealing 49 DC, 49 AC, 49 MV errorsB f=0/0 
[mpeg4 @ 01E5BA40] ac-tex damaged at 12 9   0KB sq=    0B f=0/0 
[mpeg4 @ 01E5BA40] Error at MB: 219 
[mpeg4 @ 01E5BA40] concealing 44 DC, 44 AC, 44 MV errors 
[mpeg4 @ 01E5BA40] ac-tex damaged at 4 7    0KB sq=    0B f=0/0 
[mpeg4 @ 01E5BA40] Error at MB: 165 
[mpeg4 @ 01E5BA40] concealing 66 DC, 66 AC, 66 MV errors 
[mpeg4 @ 01E5BA40] concealing 30 DC, 30 AC, 30 MV errorsB f=0/0 
[mpeg4 @ 01E5BA40] ac-tex damaged at 5 5    0KB sq=    0B f=0/0 
[mpeg4 @ 01E5BA40] Error at MB: 120 
[mpeg4 @ 01E5BA40] concealing 287 DC, 287 AC, 287 MV errors 
and billions more errors like that :-)

View this message in context: http://libav-users.943685.n4.nabble.com/get-mpeg4-streams-with-rtsp-protocol-tp2256170p3600630.html
Sent from the libav-users mailing list archive at Nabble.com.

More information about the Libav-user mailing list