[Libav-user] Beginner c++ compiling error

Alex Cohn alexcohn at netvision.net.il
Sat Sep 24 21:43:36 CEST 2011

In your list of libs, "-l" is obviously doubled. Try to give the names to
the linker without the prefix.
On Sep 24, 2011 7:58 AM, "mounir younes" <mounir.younes at gmail.com> wrote:
> Hello, I am new to ffmpeg and I am getting compiling errors while
> c++ code with ffmpeg libraries. It seems that a lot of people are getting
> this with the new ffmpeg but I couldn't find a solution that I could
> understand.
> I found a link that says that this
> (http://code.google.com/p/ffmpegsource/issues/detail?id=11)
> solves it but unfortunately I tried it but nothing happened and I don't
> what to do ! I am adding the file headers which are being automatically
> detected by netbeans so the libraries are already found. I tried adding
> these -lavdevice -lavformat -lavcodec -lavutil -lswscale -lbz2 to the
> linker as well
> (
> )
> when adding them netbeans knew them and gave them proper library icons
> it recognized that these libraries are present otherwise it would've
> replaced them with a white icon with question mark). But, when compiling I
> get this
> /usr/bin/ld: cannot find -l-lavdevice
> /usr/bin/ld: cannot find -l-lavformat
> /usr/bin/ld: cannot find -l-lavcodec
> /usr/bin/ld: cannot find -l-lavutil
> /usr/bin/ld: cannot find -l-lswscale
> /usr/bin/ld: cannot find -l-lbz2
> And this is really killing me. I have been trying to solve this for days.
> Thank you in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20110924/85445022/attachment.html>

More information about the Libav-user mailing list