[Libav-user] Does ffmpeg support non-english device name as parameter?

whatsthat whatsthat at gmail.com
Sun Apr 7 09:22:46 CEST 2013

Hi, all

I tried to use ffmpeg to record audio with Windows Chinese version and

Firstly I used -list_devices to get all audio devices, it succeed with a
list of audio devices. All these devices' name begin with some Chinese
characters not showed properly. just like below:

[dshow @ 000000000218cdc0]  "麦克�(VMware VMaudio (VMAUDIO) ("
[dshow @ 000000000218cdc0]  "电话�(VMware VMaudio (VMAUDIO) ("
[dshow @ 000000000218cdc0]  "线路输入 (VMware VMaudio (VMAUDIO) "

Then I tried to use ffmpeg to record audio as below:

ffmpeg -f dshow -i audio="麦克�(VMware VMaudio (VMAUDIO) (" -f wav test.wav

it failed with error messages:

[dshow @ 000000000241a000] Could not find audio device.
audio=麦克�(VMware VMaudio (VMAUDIO) (: Input/output error

what is the matter? Chinese device name issue?

hope some one could help me, thanks !
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20130407/0ea31f6b/attachment.html>

More information about the Libav-user mailing list