[Libav-user] told to recompile ffmpeg with -fPIC

Chan Kim ckim at etri.re.kr
Mon Dec 29 06:42:18 CET 2014

This problem was solved by adding --enable-shared when configuring ffmpeg build.


보낸 사람 : "Chan Kim" <ckim at etri.re.kr>
보낸 날짜 : 2014-12-29 13:11:20 ( +09:00 )
받는 사람 : libav-user at ffmpeg.org <libav-user at ffmpeg.org>
참조 : 
제목 : [Libav-user] told to recompile ffmpeg with -fPIC

While installing OpenCV-2.4.9 on my CentOS 6.6 x86_64 machine, I met with this error.
Linking CXX shared library ../../lib/libopencv_highgui.so
/usr/bin/ld: /usr/local/lib/libavcodec.a(vc1dsp_mmx.o): relocation R_X86_64_PC32 against symbol `ff_pw_9' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make[2]: *** [lib/libopencv_highgui.so.2.4.9] Error 1
make[1]: *** [modules/highgui/CMakeFiles/opencv_highgui.dir/all] Error 2
make: *** [all] Error 2

The message seems to tell me to recompile ffmpeg library (libavcodec.a) with -fPIC option.
But when I built ffmpeg I used(under build directory) '../configure --enable-pic' (pic is for position independent code).
I also later tried --extrac-cflags="-fPIC -m64" for the configure option. But I get the same result.
What is wrong with my situation? Any suggestion would be deeply appreciated.
How can I recompile ffmpeg with -fPIC option?
Thanks in advance.

Chan Kim

Libav-user mailing list
Libav-user at ffmpeg.org

More information about the Libav-user mailing list