[Libav-user] Unable to enable audio filter?

Ricky Huang rhuang.work at gmail.com
Tue May 6 20:32:56 CEST 2014

Hello all,

Due to dependency issues, I am running ffmpeg 0.7.16.

I am writing a custom audio filter for ffmpeg for my research.  Naturally I start out with the simplest one for reference, "anullsink" (there are really only 3 in this version anyways - anullsink, anullsrc, and anull).  However I seemed to unable to run it it.  Running:

# ./ffmpeg -y -i meowmix.mp3 -vf anullsink meowmix.wav

I am expecting to end up with an audio file meowmix.wav that has nothing.  Instead the source mp3 and destination wav files sound exactly the same.  I thought I had screwed up and rerun the previous command with "anullsrc".  Still the same.

My last attempt was to add a AV_LOG_ERROR() line in the null_filter_samples() function in asink_anullsink.c.  When I run the command again there were no error outputs.  It seemed as if the anullsink was never used…

Any help will be appreciated, thanks!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://ffmpeg.org/pipermail/libav-user/attachments/20140506/fae6d8c3/attachment.html>

More information about the Libav-user mailing list