[Libav-user] Linking error with FFmpeg 3.1.1

Fermín Ayuso Márquez fayuso83 at yahoo.es
Mon Jul 11 12:24:00 CEST 2016

Thanks! That's worked.
Is this behavior caused for any new change? In the past, I didn't use the 'Secur32.lib' and all were working OK. 

    El Lunes 11 de julio de 2016 12:08, Hendrik Leppkes <h.leppkes at gmail.com> escribió:

 On Mon, Jul 11, 2016 at 11:31 AM, Fermín Ayuso Márquez
<fayuso83-at-yahoo.es at ffmpeg.org> wrote:
> Hello!
> I've just compiled new version of FFmpeg (3.1.1). I'm using the resulting
> libraries to decode video from ip cameras. Compilation of FFmpeg was OK, but
> when I try to use them in my own program, I always have multiple linking
> errors like this:
> Error    1    error LNK2019: unresolved external symbol _FreeContextBuffer at 4
> referenced in function _tls_shutdown_client
> C:\***\libavformat.lib(tls_schannel.o)
> My configure line is:
> ./configure --toolchain=msvc --yasmexe='../dependencies/yasm/yasm.exe'
> --prefix=ffmpeg/ --disable-doc --disable-ffmpeg --disable-ffplay
> --disable-ffprobe --disable-ffserver --disable-avdevice --disable-encoders
> I tried './configure --toolchain=msvc' too, but linking errors persist.
> If I use the --disable-network option, the linking errors disappear, but I
> can't use functions like "avformat_open_input" (my code use it).
> Can anyone help me?

If you are using static linking, you need to add the additional
libraries FFmpeg might need, in this case "Secur32.lib" (a Microsoft
library for security functions)

- Hendrik
Libav-user mailing list
Libav-user at ffmpeg.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20160711/32163aaf/attachment.html>

More information about the Libav-user mailing list