[Libav-user] FFPlay (and VLC) cannot process av_sdp_create()'d SDP file for RTP stream

Weiß Christoph Christoph.Weiss at ait.ac.at
Wed Mar 9 16:12:20 CET 2016

I am still at a loss with this problem.

Is there any function or way I can force codec parameters into the SDP file?

Thanks in advance,

Von: Libav-user [mailto:libav-user-bounces at ffmpeg.org] Im Auftrag von Weiß Christoph
Gesendet: Freitag, 4. März 2016 15:07
An: libav-user at ffmpeg.org
Betreff: [Libav-user] FFPlay (and VLC) cannot process av_sdp_create()'d SDP file for RTP stream

Dear all,
I'm using the FFMpeg development libraries to generate an embedded application streaming camera images via RTP. My current example is based on the muxing.c example from FFMpeg 2.7. I use the av_sdp_create to dump the SDP before avformat_write_header and the program streams RTP packets indefinitely afterwards. With a little work, I'm able to extract a video file from packets received on the destination in Wireshark.
The content of the generated SDP is:
o=- 0 0 IN IP4
s=No Name
c=IN IP4
t=0 0
a=tool:libavformat 57.25.100
m=video 5555 RTP/AVP 96
a=rtpmap:96 MP4V-ES/90000
a=fmtp:96 profile-level-id=1
However, when I try to receive the video with ffplay, I get the following messages:
[sdp @ 0xb0400480] Could not find codec parameters (Video: mpeg4, yuv420p)
[sdp @ 0xb0400480] Estimating duration from bitrate, this may be inaccurate
test.sdp: could not find codec parameters

Is there anything missing in this SDP?
I also tried to receive the stream with VLC with the same depressing result. I also tried to use other codecs (mainly MPEG2VIDEO) during transmission, the received RTP packets seem correct in Wireshark, but playback also fails. I am at a loss about the SDP.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20160309/e3201a75/attachment.html>

More information about the Libav-user mailing list