[Libav-user] undefined reference to `vaGetDisplay'

Davood Falahati falahati.davood at gmail.com
Sun Dec 10 03:31:21 EET 2017

> https://stackoverflow.com/questions/38850260/errors-
when-compiling-c-code-with-ffmpeg-library '

Thank you Leandro,

It solved my problem. But I have another problem. When I want to run
examples in shared/ffmpeg/examples, I get "Segmentation Fault(core dumped).
This is my build script:

gcc metadata.c -L/home/dfalahati/ffmpeg_build/lib -lavdevice -lavfilter
-lavformat -lavcodec -lxcb-shm -lxcb-xfixes   -lstdc++ -lrt -lx264 -ldl
-lvpx -lpthread -lvorbisenc -lvorbis -ltheoraenc -ltheoradec -logg -lopus
-lmp3lame -lfdk-aac -lass  -lfreetype  -llzma -lbz2 -lz -lswresample
-lswscale -lavutil  -lX11 -lm  -lvdpau -lva  -lva-x11 -lva-drm -lnuma
-lva-x11 -o metadata-cmd

and when I run ./metadata-cmd myVideo.MOV , I get the explained error.
When I install libav-dev and fmpeg from ubuntu repositories, I don't have
such problems, but I need to use the newest version.

Davood Falahati
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20171210/5ba782a2/attachment.html>

More information about the Libav-user mailing list