[Libav-user] unable to play live webm chunks generated using ffmpeg webm_dash_manifest muxer and webm_chunk muxer

ravikiran.bs ravikiran.bs at zohocorp.com
Wed Jun 6 10:01:21 EEST 2018


I am using webm_dash_manifest muxer and webm_chunk muxer to generate dash manifest and webm live chunks for streaming using mpeg dash. But I am unable to play the generated chunks using the manifest file in dash-js player. The player throws the following error messages in the browser console :

"Video Element Error: MEDIA_ERR_SRC_NOT_SUPPORTED (CHUNK_DEMUXER_ERROR_APPEND_FAILED: Append: stream parsing failed. "

"Failed to remove source buffer from media source."

"Caught pending play exception - continuing (NotSupportedError: Failed to load because no supported source was found.)"

My live stream is encoded in vp8/opus codecs. The following is my manifest file generated using ffmpeg webm_dash_manifest muxer :

<?xml version="1.0" encoding="UTF-8"?>











<Period id="0" start="PT0S" >

<AdaptationSet id="0" mimeType="video/webm" codecs="vp8" bitstreamSwitching="false" subsegmentAlignment="true" subsegmentStartsWithSAP="1">

<ContentComponent id="1" type="video"/>

<SegmentTemplate timescale="1000" duration="5000" media="fetch?f=wmslive_video_$RepresentationID$_$Number$.chk" startNumber="0" initialization="fetch?f=wmslive_video_$RepresentationID$.hdr"/>

<Representation id="v3375868085" bandwidth="1000000" width="640" height="480" codecs="vp8" mimeType="video/webm" startsWithSAP="1"></Representation>


<AdaptationSet id="1" mimeType="audio/webm" codecs="opus" bitstreamSwitching="false" subsegmentAlignment="true" subsegmentStartsWithSAP="1">

<ContentComponent id="1" type="audio"/>

<SegmentTemplate timescale="1000" duration="5000" media="fetch?f=wmslive_audio_$RepresentationID$_$Number$.chk" startNumber="0" initialization="fetch?f=wmslive_audio_$RepresentationID$.hdr"/>

<Representation id="a3375868085" bandwidth="128000" audioSamplingRate="48000" codecs="opus" mimeType="audio/webm" startsWithSAP="1"></Representation>




I generate .hdr and .chk files of the actual stream using webm_chunk muxer. I am using both the muxers programmatically, not from the command line. I tried to validate my mpd using https://dashif.org/conformance.html. But that link never worked. Please help me out in fixing this issue, if my mpd is correct or not. Because, my player would make request of hdr files and then it would stop, without triggering any chunk requests at all.

Ravi Kiran B S

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://ffmpeg.org/pipermail/libav-user/attachments/20180606/6ea7e9a2/attachment.html>

More information about the Libav-user mailing list