[Ffmpeg-devel] Need -maltivec in addition to -faltivec for OSX

Dan Villiom Podlaski Christiansen danchr
Fri Aug 12 14:48:55 CEST 2005

On 10/08/05, Steven M. Schultz <sms at 2bsd.com> wrote:
> Hi -
>         Ok - now that the other changes have been addressed
>         here's the remaining (single line) change for ./configure  as
>         a patch by itself.
>         Cheers,
>         Steven Schultz


I suspect that this patch may be incorrect, or at least might have
some unwanted side-effects. From reading the documentation, using
-maltivec will allow GCC to generate AltiVec instructions from
ordinary, non-vectorised C-code. Currently, an AltiVec-enabled build
of FFmpeg should work on a G3, and using -maltivec might break this.
Have you verified that this still works on a G3s? If not, I may be
able to check it later.

It's worth noting that -mcpu=G4 and -mcpu=G5 imply -maltivec.

- Dan Christiansen

More information about the ffmpeg-devel mailing list