[Ffmpeg-devel] Need -maltivec in addition to -faltivec for OSX

Steven M. Schultz sms
Fri Aug 12 18:59:48 CEST 2005

On Fri, 12 Aug 2005, Dan Villiom Podlaski Christiansen wrote:

> I suspect that this patch may be incorrect, or at least might have
> some unwanted side-effects. From reading the documentation, using
> -maltivec will allow GCC to generate AltiVec instructions from
> ordinary, non-vectorised C-code. Currently, an AltiVec-enabled build

	That is precisely and exactly the intended effect ;)

	If you're  building for a G4 or G5 _and_ -faltivec has been
	specified then you want the compiler to generate the vectorized 
	memset().  The warning error from the compiler was:

> of FFmpeg should work on a G3, and using -maltivec might break this.

	It shouldn't break anything since "-maltivec" is only being enabled
	IF the Altivec capability exists:

	  if test $altivec = "yes"; then

	If you've a G3 then -faltivec and -maltivec will NOT be defined.

> Have you verified that this still works on a G3s? If not, I may be
> able to check it later.

	No, I don't have anything that old :)

	But ./configure on a G3 will not detect altivec and will not turn on
	any of the Altivec flags - everything'll work just fine from what I
	can see.

	Steven Schultz

More information about the ffmpeg-devel mailing list