[Ffmpeg-devel] Re: 0.4.9-pre2?

Jacob Meuser jakemsr
Wed Jun 29 21:19:40 CEST 2005

On Wed, Jun 29, 2005 at 11:51:53AM -0400, Robert Lippmann wrote:
> > > no, not everyone.  you forget that most users use packages.  do you
> > > really think everyone who uses FFmpeg has the desire/ability to track
> > > FFmpeg cvs?
> >
> > E.g. Debian ships ffmpeg CVS snapshots instead of release tarballs.
> >
> Most distros do (eg gentoo, fedora [via extras or freshrpms]).  I imagine
> the *BSD maintainers work similarly.

yes (well NetBSD is still using 0.4.8).  but that doesn't solve the
problem with other projects using FFmpeg, which is IMHO, more of an

> The distro package maintainer usually starts with an upstream release and
> patches from there.  If snapshots weren't used, there'd probably lots of
> patches they'd have to maintain which are redundant with fixes from CVS.

right.  and some distros/OSes have a policy that _only_ releases
can be used in official packages.  yes, sometimes exceptions can
be made, but still, what about other projects using FFmpeg?
we constantly have people saying, "I can't get transcode to
compile against FFmpeg."  so then we have to find out what version
of FFmpeg they are using, and even tell them how to compile FFmpeg.

<jakemsr at jakemsr.com>

More information about the ffmpeg-devel mailing list