[Ffmpeg-devel] ffmpeg crashes on windows

Michel Bardiaux mbardiaux
Fri May 6 12:09:54 CEST 2005

eleven wrote:
> Hi again,
> I'll give some more info. I installed ffmpeg as i
> mentioned and tried to run the tutorial of martin at:
> http://www.inb.uni-luebeck.de/~boehme/using_libavcodec.html
> I ran it on linux and i know it works. 

Then post the command lines you used on Linux and their ouput, to be 
used as reference.

> So when i tried
> to compile the software on windows 

How exactly? Platform (mingw or cygwin), version of gcc, configure 
command? (Maybe you already posted that, doesnt matter, when asked for 
details reply with a *detailed complete answer*, not just the detail 

> it always crashes
> and windows tells me program has caused an illegal
> operation. Nothing more is said regretabbly.

Command line? Output?

> So then i tried ffmpeg.exe -i x.mpg
> just to see if ffmpeg works and that crashes as well
> with no info whatsoever. 

Not even the version string? What about ffmpeg -h and ffmpeg -formats?

> So i was thinking it's
> probably my machine that is the problem since there is
> only one way to install ffmpeg as far as i know.
> Actually i tried with and without enable-shared and
> it's still the same. So that's why i gave so much info
> on the machine i'm using. Let me know if u guys need
> anything else

What is needed is enough info to be able to reproduce (maybe) the 
problem without having to dig in umpteen mails and a tutorial. This is 
ffmpeg-devel, not archeology 101; and you failed to prove it is a bug 
and not some 'user error'.

> cheers

Michel Bardiaux
Peaktime Belgium S.A.  Bd. du Souverain, 191  B-1160 Bruxelles
Tel : +32 2 790.29.41

More information about the ffmpeg-devel mailing list