[Ffmpeg-devel] ffmpeg crashes on windows

Anders Nilsson breakin.outbreak
Mon May 9 23:06:34 CEST 2005

I've happily used ffmpeg in my code for quite some time. Currently I
tried encoding a video and it just didn't worked anymore. I have
updated the CVS since it last worked so something happened there.
Naturally I got the very latest version from the CVS and rebuilt but
it still doesn't work! I thought it was my own fault somehow but it
seems other have been suffering from the same problems on the list.
Here's a list of what does not work:

ffmpeg.exe crashes (access violation, no output)
output_example.exe works but says "could not open codec" for any
format I've tried

The same thing happens to my own code; avcodec_open does not work
anymore! It returns something <0 for ANY format I've tried. FFmpeg.exe
might never have worked on my computer - never tried it before - but
output_example worked alright before and so did my own code.

I compile using MINGW32 with visual studio .2003 for creating the
.DLL-files. Lotsa warnings during compile (as always) but no errors.

Hope I'm not wasting your time!

Anders Nilsson

This is the output from ./configure

$ ./configure --enable-shared --enable-memalign-hack 
Install prefix   /c/Program Files/FFmpeg
Source path      /*censor*/win32/extern/ffmpeg-source
C compiler       gcc
make             make
CPU              x86 (generic)
Big Endian       no
inttypes.h       yes
broken inttypes.h no
MMX enabled      yes
Vector Builtins  no
gprof enabled    no
zlib enabled     no
mp3lame enabled  no
libogg enabled   no
vorbis enabled   no
theora enabled   no
faad enabled     no
faadbin enabled  no
faac enabled     no
xvid enabled     no
x264 enabled     no
a52 support      no
a52 dlopened     no
dts support      no
pp support       no
debug symbols    yes
strip symbols    yes
optimize         yes
shared pp        no
Video hooking    no
SDL support      no
Sun medialib support no
pthreads support no
AMR-NB float support no
AMR-NB fixed support no
AMR-WB float support no
AMR-WB IF2 support no
network support      no
License: LGPL

Then I do make and make install.

More information about the ffmpeg-devel mailing list