[Ffmpeg-devel] how to compile output_example.c

Turbo sandeep_kr
Sun Aug 6 18:54:12 CEST 2006

Thanx for ur help.
On Sun, 6 Aug 2006, Luca Abeni wrote:

> Hi,
> On Sun, 2006-08-06 at 16:38 +0530, Turbo wrote:
> [...]
>>> Are you sure that the avcodec, avformat, and avutil libraries that you
>>> are trying to link are really the latest one from svn? (maybe they are
>>> coming from a previous installation?)
>> I think I am using the latest svn. How to make sure?
>> Should I attach my code? Its almost same as output_example.c and
>> you wouldn't have to spend much time on it.
>> From the error messages you posted, it looks like you are trying to link
> an output_example using sws (similar to the one from the svn repository)
> with libraries that do not implement the sws emulation (that is, with
> old av* libraries).
> Try to use nm or objdump to check if the libav{codec, format, util}
> libraries from /usr/local/lib contain sws_* symbols.
'nm /usr/local/lib/libavcodec.a | grep sws' gives:-
00000d90 T sws_freeContext
00000c50 T sws_getContext
00000df0 T sws_scale
'nm /usr/local/lib/libavformat.a | grep sws' gives no output
'nm /usr/local/lib/libavutil.a | grep sws' gives no output

I assume the library u asked are libavcodec.a libavformat.a and 
libavutil.a. (I am a newbie :) )
Also if I am using old libraries then why is output_example.c from the svn 
compiling without any errors ?
> 				Luca
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at mplayerhq.hu
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-devel

I do know everything, just not all at once. It's a virtual memory problem.
Home Page : http://students.iiit.ac.in/~sandeep_kr
Blog : http://sandy007smarty.blogspot.com

More information about the ffmpeg-devel mailing list