[Ffmpeg-devel] [MacIntel] Testers welcome!

Ulrich von Zadow coder
Sun Aug 13 11:27:04 CEST 2006

Diego Biurrun wrote:
> On Sat, Aug 12, 2006 at 08:29:34PM +0200, Ulrich von Zadow wrote:
>> Guillaume POIRIER wrote:
>>> The last part of patches to add MacIntel support has been committed.
>>> Could the ppl who have access to any of these machines confirm that it 
>>> works?
>> Works here using plain ./configure and ./configure --disable-shared 
>> --disable-debug --disable-encoders.
>> It is still nessesary to run ranlib on the static libraries after make 
>> install, though, so make install is missing a step.
> Hmmm?  ranlib is run on the static libraries, look at the rule in the
> Makefile that creates them:
>         rm -f $@
>         $(AR) rc $@ $^ $(EXTRAOBJS)
>         $(RANLIB) $@

The error is '../lib/libavformat.a is out of date; rerun ranlib(1) 
(can't load from it)'. Running ranlib after install solves the issue. 
This is Mac-specific.



More information about the ffmpeg-devel mailing list