MPEG seek crash (was: [Ffmpeg-devel] Re: Compiling FFmpeg using ISO/C89 compiler)

Steve Lhomme slhomme
Fri Dec 8 16:51:46 CET 2006

Guillaume POIRIER wrote:
> Hi,
> (quoting the relevant parts of he old mpeg-2 crash thread)
> On 12/8/06, Diego Biurrun <diego at> wrote:
>> This issue is now buried in an old and long-forgotten thread.  Please
>> submit a new bug report along with the sample and clear steps to
>> reproduce the problem.
> Steve wrote:
>> So the problem is dynamic. You need to read/decode frames before seeking
>> for the crash to occur. That's why only trying with ffplay produces the
>> crash. And only after modifying it (since it's dynamic it's almost
>> impossible to seek to the location where you want it to crash).
> Steve wrote:
>> OK, I only added the possibility in ffplay to seek by bytes instead of
>> time. Now you can play chems1.vob, seek back a few times and it will
>> crash (on MinGW at least). It doesn't with our custom patch that was
>> discussed a long time ago as a non valid/clean solution.
>> $ ./ffplay.exe -bytes /C/test/DivX/chems1.vob

I booted to Linux (Ubuntu) and compiled the latest FFMPEG SVN. I ran the 
same command and after 1 or more push of the left/right arrows I got the 
same crash.

I tried to run gdb on ffplay_g but didn't get any meaningful 
information, nothing (NULL) in the backtrace only a line in mpegvideo.c 
is mentioned.


More information about the ffmpeg-devel mailing list