[Ffmpeg-devel] Re: ffmpeg could not grab from video device while is not open xawtv

Martin Farnik martin.farnik
Tue Jun 6 13:02:31 CEST 2006

Hi Luca,

On Mon, 2006-06-05 at 12:52 +0200, Martin Farnik wrote:
> ffmpeg -vd /dev/video0 -an -s 720x576 -f mpeg -tvstd PAL -b 1024 -y
> ./test.mpg
> i will get:
> FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
>   configuration:  
>   libavutil version: 49.0.0
>   libavcodec version: 51.9.0
>   libavformat version: 50.4.0
>   built on May 31 2006 11:49:22, gcc: 3.4.1 (Mandrakelinux (Alpha 3.4.1-3mdk)
> [video4linux @ 0x82d1184]Fatal: grab device does not support suitable format
> Could not find video grab device
I just tried, and it worked here with an Osprey 100 card...

I use WinFast VC100XP. So I read on some discussion forum that there was bug in bttv module for this card (card=114 ) - module doesn't  create /dev/video device(in my bttv module  version it was true). So I used card PV 951(card=42) where is Conexant 878A chip instead.
With this card it has done  described error. 

I try to load bttv module with you card (Osprey 100 card=82) and the grabbing seems working ok.

Thanks for hint.


More information about the ffmpeg-devel mailing list