[Ffmpeg-devel] about mingw compiling problem (and possible solution)

Gianluigi Tiesi mplayer
Wed Oct 4 14:36:12 CEST 2006

On Wed, Oct 04, 2006 at 12:07:26AM +0100, M?ns Rullg?rd wrote:
> Gianluigi Tiesi said:
> > Finally I've got the problem that some users sperimented.
> > The problem is that the code that checks for a valid shell
> > executes bash from cygwin that has different /tmp directory.
> > A quick and dirty patch for ppl that want to compile it on mingw
> > is appling this patch, dunno about a real solution,
> > it seams that the script doesn't consider mingw bash as a valid
> > shell but in effect it's a valid shell.
> The standard mingw bash (2.04) *is* broken.  You need to install 2.05
> or later.
GNU bash, version 2.04.0(1)-release-(i686-pc-msys)
works fine too, but bash 3.1 snapshot solves the problem
with configure.
So please put some info somewhere for mingw build
to download the 3.1 snapshop to avoid problems.


Gianluigi Tiesi <sherpya at netfarm.it>
EDP Project Leader
Netfarm S.r.l. - http://www.netfarm.it/
Free Software: http://oss.netfarm.it/

More information about the ffmpeg-devel mailing list